[SciPy-User] site.cfg problems : scipy can't find BLAS

John Reid j.reid@mail.cryst.bbk.ac...
Tue Apr 13 03:02:43 CDT 2010

John Reid wrote:
> Thanks for the help Patrick, Minh-Tri, Josef and David.
> I can get scipy compiled but its still failing the tests. When I run 
> with verbose=10 I can identify the test it is running:
I just thought I'd let everyone know I've worked around these problems 
with the following steps:

- I've gone back to numpy 1.3.0 and scipy 0.7.1
- I follow the instructions for Ubuntu at 
but I replace the building ATLAS step by building GotoBLAS2 and a netlib 
LAPACK that uses it

My new site.cfg is:
library_dirs = /usr/local/src/scipy-stack/lib
include_dirs = /usr/local/src/scipy-stack/include

libraries = goto2
language = fortran

libraries = lapack goto2
language = fortran

amd_libs = amd

umfpack_libs = umfpack

libraries = fftw3

I hope that helps anyone else who has similar problems. Thanks all for 
the help.


More information about the SciPy-User mailing list