[SciPy-User] Suggest moving curve_fit from minpack to top level
Wed Feb 24 08:18:28 CST 2010
On Wed, Feb 24, 2010 at 9:07 AM, Pim Schellart <email@example.com> wrote:
> Dear Scipy users,
> I would like to suggest moving the curve_fit wrapper function from the
> minpack module to the top level and possibly renaming it to "fit".
> So you could access it using:
> import scipy as sp
> Curve fitting is one of the most important tasks in scientific
> analysis and most people starting with scipy struggle to find this
> (undocumented) function, especially when moving to scipy from gnuplot
> which has a basic fit function that performs the same task.
> What are your thoughts about this?
I don't think it's a good idea.
I almost never import scipy directly, only
from scipy import optimize, stats
import scipy.linalg as splinalg
The pure scipy.* namespace is pretty empty
"fit" is a term that is too generic, polyfit, linear fit, ....
curve_fit will hopefully sufficiently documented and included in the
docs when it is included in a release of scipy.
>>> import this # last item
> Kind regards,
> Pim Schellart
> SciPy-User mailing list
More information about the SciPy-User