[SciPy-User] scikits.timeseries or matplotlib plotting problem?

Dharhas Pothina Dharhas.Pothina@twdb.state.tx...
Thu Jan 14 08:02:16 CST 2010

I've had this problem before. From the email exchange I had on this
list about a year ago, I basically worked out that any symbols work fine
ie: dot,circle, diamond etc. When you use line types like '-' or '--'
and have missing or masked data  in the timeseries the plotting
functions don't know what to do and just fail. From what I undesrtand
this is a matplotlib issue and a work around is to compress the array to
remove the missing values before plotting. See:


- dharhas

>>> Pawe* Rumian <gorkypl@gmail.com> 1/14/2010 2:15 AM >>>
> Cool ! You can also check scikits.hydroclimpy, a set of extensions
> scikits.timeseries with focus on climate analysis.

I'm reading the docs right now - seems that I've reinvented the wheel
The good side is that I've started two weeks ago, so I didn't manage
to waste too much time.

> Might be a bug recently introduced. Let me check and get back to

After more testing it seems to me more like a bug in matplotlib.
It occurs only when plotting lines, using '-' or '--'. When I changed
marks to '.', it worked.

> Lemme know if you need more help or if the doc is lacking on some

I will be playing with this stuff for at least a year, so I probably
will :)

Anyway - great job!

Pawe* Rumian
SciPy-User mailing list

More information about the SciPy-User mailing list