[SciPy-User] curve_fit missing from scipy.optimize

Charles R Harris charlesr.harris@gmail....
Fri Jul 16 01:10:44 CDT 2010

On Thu, Jul 15, 2010 at 11:52 PM, Benedikt Riedel <briedel@wisc.edu> wrote:

> Hey,
> It is Ubuntu 10.04 on an AMD-64 from the alternative install CD. I first
> installed
Same here except AMD Phenom.

> build-essential gfortran libatlas-sse2-dev
Special SSE2 packages are a 32 bit thing, are you running the 32 bit version
of Ubuntu?

> python-all-dev ipython
> subversion
> via apt-get. Then I installed nose, numpy and finally scipy using the
> package from the website
Usually I apt-get numpy and scipy for the dependencies, then install from
svn. If you do install from source in addition to the ubuntu packages you
might want to modify the path so the proper package is used. I use

$charris@ubuntu ~$ cat ~/.local/lib/python2.6/site-packages/install.pth

Although I suspect /usr/local/lib/python2.6/site-packages would work as

> http://python-nose.googlecode.com/files
> http://superb-east.dl.sourceforge.net/sourceforge/numpy
> http://voxel.dl.sourceforge.net/sourceforge/scipy/
>  When I first installed it. Nose and numpy went through fine, but scipy
> installation had some g++ problems, so I had to install a new g++. I tried
> it out and optimize was screwed.
> When that did not work, I installed 0.7.0 via the Ubuntu software center.
> After that optimize worked, but curve_fit was gone. So back to 0.7.2 I went
> to and optimize now worked, but curve_fit still did not.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20100716/76a36c40/attachment.html 

More information about the SciPy-User mailing list