[SciPy-User] timeseries plotting with two y axes

Solomon Negusse Solomon.Negusse@twdb.state.tx...
Wed Mar 16 09:09:07 CDT 2011

Hi Hannah, 
I'm using matplotlib1.0.1 and scikits.timeseries0.91.3 so I'm not sure if mine is the same incompatibility problem.But I worked around the problem yesterday by using  matplotlib's plot_dates instead which works for now but doesn't give you the neat axis autoscaling that timeseries'  plotlib does. In any case I'll test your patched version and see if it works. 
Thanks a lot,

>>> hannah aiznman <story645@yahoo.com> 3/15/2011 10:00 PM >>>
>Solomon Negusse <Solomon.Negusse <at> twdb.state.tx.us> writes:
> fig = tpl.tsfigure()   
> fsp = fig.add_tsplot(111)   
> raw_salinity =
> fsp.tsplot(datasonde_series['Salinity'],'r.')    fsp.set_ylim(0,100)   
> fsp.set_dlim(sdate,edate)    
> fsptemp = fsp.twinx()
> water_level = fsptemp.tsplot(datasonde_series['WaterDepth'],'b.')   
> Doing this I get an error :  'Axes' object has no attribute tsplot.  

What version of timeseries and matplotlib are you using? There's an
incompatibility between two versions that requires patching timeseries, and I
remember getting the bug specifically when I tried to add subplots. See here for
more instructions and a possible fix:

SciPy-User mailing list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20110316/ff2afceb/attachment.html 

More information about the SciPy-User mailing list