[SciPy-User] Segmentation fault with scipy v0.9.0

Baker D.J. D.J.Baker@soton.ac...
Tue Sep 20 10:43:37 CDT 2011


I'm building scipy v0.9.0 on a RHELS 5.3 cluster. I'm building the package with python 2.6.5, numpy 1.6.1 and the GNU compilers v4.1.2. I've kept things simple and just used the "bog standard" BLAS/LAPACK installed via RHELS rpms. I've  built and tested numpy today and that is fine. On the other hand I find that the scipy tests fail with a segmentation fault. On running the tests with "scipy.test(verbose=2) I find the following failure:

test_nonlin.TestJacobianDotSolve.test_broyden1 ... Segmentation fault

We do have the Intel compilers and MKL on our system as well, however I'll work with these as a last resort. The last time I tried to build scipy using these packages I ran in to many issues. Does anyone please have any advice for me re building scipy 0.9.0 successfully? If, for example, you have a successful build of v0.9.0 then I would appreciate knowing how you did it.

Best regards - David.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20110920/92a9cc12/attachment-0001.html 

More information about the SciPy-User mailing list