[SciPy-User] Spyder-Ubuntu 12.04 problem with SciPy 0.11.0rc1

Virgil Stokes vs@it.uu...
Sun Jul 22 04:20:35 CDT 2012

On 22-Jul-2012 09:14, Scott Sinclair wrote:
> On Jul 21, 2012 1:19 PM, "Virgil Stokes" <vs@it.uu.se <mailto:vs@it.uu.se>> wrote:
> >
> > I installed SciPy 0.11.0rc1 on an Ubuntu 12.04 (64-bit) platform with what
> > seemed to be no problems.
> > However, when I ran Spyder it still was using SciPy 0.10.1. I then tried to
> > uninstall SciPy completely using
> >
> >   >pip uninstall SciPy
> >
> > which again seemed to be ok. But, now I was unable to execute Spyder! I tried
> > several times to uninstall and reinstall Spyder but I am stuck with no
> > possibility to run Spyder. I get no error; but, clicking in this application in
> > Ubuntu 12.04 seems to be ignored.
> >
> > Any suggestions as to how to recover Spyder and how to get SciPy running again
> > would be appreciated.
> I don't know about Spyder (I don't use it and you haven't given much 
> information about how you tried to un/reinstall it). I suspect it was via the 
> package manager?
> Did you run pip uninstall with sudo?
> What happens when you run:
> python -c "import scipy; print scipy.__version__; print scipy"
> at the command line?
> If you get an import error for scipy try reinstalling python-scipy from the 
> package manager.
> Cheers,
> Scott
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
Ok Scott,
I tried some more things; but, first here is what I get when I try to run Spyder 
from a command line:

root@virgil-laptop:/usr/local/bin# spyder
Traceback (most recent call last):
   File "/usr/local/bin/spyder", line 2, in <module>
     from spyderlib import spyder
   File "/usr/local/lib/python2.7/dist-packages/spyderlib/spyder.py", line 91, 
in <module>
     from spyderlib.utils.environ import WinUserEnvDialog
   File "/usr/local/lib/python2.7/dist-packages/spyderlib/utils/environ.py", 
line 17, in <module>
     from spyderlib.widgets.dicteditor import DictEditor
"/usr/local/lib/python2.7/dist-packages/spyderlib/widgets/dicteditor.py", line 
31, in <module>
     from spyderlib.config import get_icon, get_font
   File "/usr/local/lib/python2.7/dist-packages/spyderlib/config.py", line 27, 
in <module>
     from spyderlib.utils import iofuncs, codeanalysis
   File "/usr/local/lib/python2.7/dist-packages/spyderlib/utils/iofuncs.py", 
line 33, in <module>
     import scipy.io as spio
   File "/usr/local/lib/python2.7/dist-packages/scipy/io/__init__.py", line 83, 
in <module>
     from matlab import loadmat, savemat, byteordercodes
   File "/usr/local/lib/python2.7/dist-packages/scipy/io/matlab/__init__.py", 
line 11, in <module>
     from mio import loadmat, savemat
   File "/usr/local/lib/python2.7/dist-packages/scipy/io/matlab/mio.py", line 
15, in <module>
     from mio4 import MatFile4Reader, MatFile4Writer
   File "/usr/local/lib/python2.7/dist-packages/scipy/io/matlab/mio4.py", line 
9, in <module>
     import scipy.sparse
   File "/usr/local/lib/python2.7/dist-packages/scipy/sparse/__init__.py", line 
182, in <module>
     from csgraph import *
AttributeError: 'module' object has no attribute 'csgraph_to_masked'

I installed scipy-0.10.1 and then tried to run Spyder --- the following crash 
report was generated:

The crashed program seems to use third-party or local libraries:


It is highly recommended to check if the problem persists without those first.

Do you want to continue the report process anyway?

Interestingly, a search for csgraph in the file system gives nothing.

Do you have any suggestions as to how to fix Spyder-SciPy?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20120722/cc0256b6/attachment.html 

More information about the SciPy-User mailing list