[SciPy-User] qHull zero division error, scipy 0.10.1, linux

David Baddeley david_baddeley@yahoo.com...
Mon Jul 30 19:42:23 CDT 2012

I get a zero division error following error when trying to use the qHull bindings in scipy.spatial, e.g.

In [8]: from scipy.spatial import qhull
In [9]: qhull.Delaunay(randn(100, 2))
ZeroDivisionError                         Traceback (most recent call last)
/home/david/<ipython console> in <module>()
/usr/local/lib/python2.6/dist-packages/scipy-0.10.1-py2.6-linux-x86_64.egg/scipy/spatial/qhull.so in scipy.spatial.qhull.Delaunay.__init__ (scipy/spatial/qhull.c:4109)()
/usr/local/lib/python2.6/dist-packages/scipy-0.10.1-py2.6-linux-x86_64.egg/scipy/spatial/qhull.so in scipy.spatial.qhull._construct_delaunay (scipy/spatial/qhull.c:1344)()
ZeroDivisionError: float division

All the tests involving the qhull module also fail with the same error if I run scipy.test().

full system details below:

NumPy version 1.6.2
NumPy is installed in /usr/local/lib/python2.6/dist-packages/numpy-1.6.2-py2.6-linux-x86_64.egg/numpy
SciPy version 0.10.1
SciPy is installed in /usr/local/lib/python2.6/dist-packages/scipy-0.10.1-py2.6-linux-x86_64.egg/scipy
Python version 2.6.5 (r265:79063, Apr 16 2010, 13:57:41) [GCC 4.4.3]
nose version 1.1.2
Ubuntu 10.04 LTS x64

both numpy and scipy were installed using easy_install.

before I download the source and start messing with qhull.pyx / the qhull sources themselves. I thought I'd ask if there were any known bugs / clues.

many thanks, 

More information about the SciPy-User mailing list