[SciPy-User] numpy - scipy test failure on OSX (git version 10/3/2012)

Massimo Di Stefano massimodisasha@gmail....
Mon Mar 12 03:15:54 CDT 2012

I tried to upgrade to Xcode 4.3 .. but seems that 'for free' there is only Xcore 4.2 on the apple dev center.

i installed the gcc from the crane website and i exported the flags .. but numpy build is giving me word error about array with negative size.

here [1] the full log using the gcc from the R website.

[1] http://www.geofemengineering.it/numpy_build_log.txt

i think it i is the cause of all the evil … i should fix this before to go a had with scipy.

frustrated i also tried to build gcc4.6 from source  .. but no lucky the setup.py ends with :

MacBook-Pro-di-Massimo:numpy epifanio$ export CC=/usr/local/bin/gcc
MacBook-Pro-di-Massimo:numpy epifanio$ export CXX=/usr/local/bin/g++
MacBook-Pro-di-Massimo:numpy epifanio$ rm -rf build/
MacBook-Pro-di-Massimo:numpy epifanio$ python setup.py build_ext --fcompiler=/usr/local/bin/gfortran-4.2
Running from numpy source directory.
non-existing path in 'numpy/distutils': 'site.cfg'
F2PY Version 2
numpy/core/setup_common.py:86: MismatchCAPIWarning: API mismatch detected, the C API version numbers have to be updated. Current C api version is 6, with checksum eb54c77ff4149bab310324cd7c0cb176, but recorded checksum for C API version 6 in codegen_dir/cversions.txt is e61d5dc51fa1c6459328266e215d6987. If functions were added in the C API, you have to update C_API_VERSION  in numpy/core/setup_common.pyc.
    extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
    define_macros = [('NO_ATLAS_INFO', 3)]
    extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']

    extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
    define_macros = [('NO_ATLAS_INFO', 3)]
    extra_compile_args = ['-msse3']

running build_ext
running build_src
building py_modules sources
creating build
creating build/src.macosx-10.7-intel-2.7
creating build/src.macosx-10.7-intel-2.7/numpy
creating build/src.macosx-10.7-intel-2.7/numpy/distutils
building library "npymath" sources
customize NAGFCompiler
Could not locate executable f95
customize AbsoftFCompiler
Could not locate executable f90
Could not locate executable f77
customize IBMFCompiler
Could not locate executable xlf90
Could not locate executable xlf
customize IntelFCompiler
Could not locate executable ifort
Could not locate executable ifc
customize GnuFCompiler
Could not locate executable g77
customize Gnu95FCompiler
Found executable /usr/local/bin/gfortran
customize Gnu95FCompiler
customize Gnu95FCompiler using config
C compiler: /usr/local/bin/gcc -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -mno-fused-madd -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe

compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -Inumpy/core/include -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c'
gcc: _configtest.c
gcc: warning: ‘-mfused-madd’ is deprecated; use ‘-ffp-contract=’ instead
gcc: error: i386: No such file or directory
gcc: error: x86_64: No such file or directory
gcc: error: unrecognized option ‘-arch’
gcc: error: unrecognized option ‘-arch’
gcc: warning: ‘-mfused-madd’ is deprecated; use ‘-ffp-contract=’ instead
gcc: error: i386: No such file or directory
gcc: error: x86_64: No such file or directory
gcc: error: unrecognized option ‘-arch’
gcc: error: unrecognized option ‘-arch’
removing: _configtest.c _configtest.o
Traceback (most recent call last):
  File "setup.py", line 214, in <module>
  File "setup.py", line 207, in setup_package
    configuration=configuration )
  File "/Users/epifanio/dev/src/numpy/numpy/distutils/core.py", line 186, in setup
    return old_setup(**new_attr)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/core.py", line 152, in setup
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 953, in run_commands
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 972, in run_command
  File "/Users/epifanio/dev/src/numpy/numpy/distutils/command/build_ext.py", line 57, in run
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/cmd.py", line 326, in run_command
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 972, in run_command
  File "/Users/epifanio/dev/src/numpy/numpy/distutils/command/build_src.py", line 152, in run
  File "/Users/epifanio/dev/src/numpy/numpy/distutils/command/build_src.py", line 163, in build_sources
  File "/Users/epifanio/dev/src/numpy/numpy/distutils/command/build_src.py", line 298, in build_library_sources
    sources = self.generate_sources(sources, (lib_name, build_info))
  File "/Users/epifanio/dev/src/numpy/numpy/distutils/command/build_src.py", line 385, in generate_sources
    source = func(extension, build_dir)
  File "numpy/core/setup.py", line 648, in get_mathlib_info
    raise RuntimeError("Broken toolchain: cannot link a simple C program")
RuntimeError: Broken toolchain: cannot link a simple C program
MacBook-Pro-di-Massimo:numpy epifanio$ 

maybe i missed something during the gcc configure ???

Il giorno Mar 12, 2012, alle ore 1:29 AM, Scott Lasley ha scritto:

> On Mar 11, 2012, at 4:53 PM, Massimo Di Stefano wrote:
>> Hi All,
>> i'm on OSX lion using the system python.
>> i just finished to build numpy and scipy  using the later gig version and i tried to run the test.
>> unlucky bumpy failed ands scipy test gives me a segfault.
>> i hope something is wrong on my system .. have you any hints on how to debug this problem ?
>> attached a link to the test log [1].
>> [1] http://www.geofemengineering.it//numpy_scipy_log.txt
> Which version of Xcode do you have?  I got a segfault in the scipy tests after building with the llvm-gcc included with Xcode 4.2.  I have not tried building scipy with the latest llvm-gcc included with Xcode 4.3, but building with clang or gcc-4.2 from the cran.r-project worked.  See this message for more information
> http://mail.scipy.org/pipermail/scipy-user/2012-February/031460.html
> hth,
> Scott
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user

More information about the SciPy-User mailing list